Sappiamo che Facebook attua cambiamenti improvvisi con una rapidità quasi impressionante: oggi ha deciso di cambiare le sua API e così eccoci pronti a darvi una mano con i vostri siti! Spieghiamo di seguito cosa bisogna fare per integrare le nuovi API di Facebook in HTML 5 all’interno del proprio sito, in particolare su siti WordPress.

Ecco il codice che dovete inserire nell’header:

<div id="fb-root"></div>
<script>(function(d, s, id) {
var js, fjs = d.getElementsByTagName(s)[0];
if (d.getElementById(id)) {return;}
js = d.createElement(s); js.id = id;
js.src = "//connect.facebook.net/it_IT/all.js#xfbml=1";
fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));</script>

al posto di questa porzione di codice:

(function(d){
var js, id = 'facebook-jssdk'; if (d.getElementById(id)) {return;}
js = d.createElement('script'); js.id = id; js.async = true;
js.src = "//connect.facebook.net/it_IT/all.js#xfbml=1";
d.getElementsByTagName('head')[0].appendChild(js);
}(document));

che vi avevamo consigliato già nel precedente articolo per passare alle API in HTML5. GLi iframe non sono più supportati, quindi molti siti dovranno necessariamente aggiornarsi. Per quanto riguarda il codice per i vari social plugin, basterà seguire le istruzioni descritte  nell’articolo precedente.

Ti invieremo un' email a settimana, puoi cancellare l'iscrizione in qualunque momento.

Potrebbe interessarti anche:


LASCIA UN COMMENTO

Please enter your comment!
Scrivi il tuo nome